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What is Matlab?What is Matlab?

Matrix Laboratories which is a registered trademark of the 
MathWorks, Inc. 

The first version of Matlab was written in 1970s by a 
numerical analyst named Cleve Moler.

Basic Feature:

… is a high performance programming language and a 
computing environment that uses vectors and matrices as 
one of its basic data types and is a powerful tool for 
mathematical and technical calculations and for creating 
various types of plots.
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What is Matlab?What is Matlab?

It performs the basic functions of a programmable calculator 
whereas someone can write, run/execute and save a bundle 
of commands sentence by sentence.

it integrates computation, visualization and programming in 
an easy to use environment via a subtle mathematical 
notation. 

Matlab has a broad spectrum of uses since it is keeping 
expanded by MathWorks, Inc. as well as by user defined 
programming codes. For example, the primary versions of 
Matlab were made for solving linear algebra type problems 
using matrices. Today, Matlab can be used in more fields.

Most Important: You Learn By Doing!!!
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Two Important FeaturesTwo Important Features

Data Elements: 

Its basic data element is an array that does not require 
dimensioning. That is, there is only one type of variable that is 
treated as a rectangular array. It can be either a scalar, either a 
row or column vector or a matrix. 

Extensible and Powerful Language:

Matlab features a family of add-on application-specific solutions 
called toolboxes. A toolbox is a comprehensive collection of 
Matlab functions (m-files) that extend the Matlab environment to 
solve particular classes of problems. Additionally, the user is free 
to create its own classes of functions to deal with specialized 
problems.
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Starting Up MatlabStarting Up Matlab

Step 1: Use the [Ctrl]+[Alt]+[Del] combination to bring up the logon 
screen (at this point you should enter the user name and your 
password and after to press [Enter])

Step 2: After few seconds, you can view the PC’s Desktop screen with 
all available icons. Find the Matlab’s shortcut icon (labeled as “Matlab” 
and looks like:      ) and double click on it. After few moments, the 
Matlab starts up and the following words appear in one of the 
screens:

Step 3: The Matlab is now ready to be used! (if you want to quit 
Matlab, from the window named as Command Window either type 
quit or exit from the toolbar choose: File > Exit Matlab ) 

To get started, select "MATLAB Help" from the Help menu
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Matlab’s Window: DesktopMatlab’s Window: Desktop
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Matlab’s Window: Command WindowMatlab’s Window: Command Window

It is the main window in which 
the user communicates with the 
software. In the command 
window, the user can view the 
prompt symbol “>>” which 
indicates that Matlab is ready to 
accept various commands by 
the user. 

Via this window, the user can employ the basic arithmetic operators like: 
“+” (addition), “-” (subtraction), “*” (multiplication), “/” (division), “^” 
(powers) and the “( )” (brackets), as well as many other build in 
elementary functions and commands
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Matlab’s Window: WorkspaceMatlab’s Window: Workspace

The Matlab workspace
consists of the set of 
variables (named 
arrays) built up during a 
Matlab session and 
stored in memory. 

You add variables to the workspace by using functions, running 
m-files, and loading saved workspaces. The workspace is not 
maintained after you end the Matlab session. To save the 
workspace to a file that can be read during a later Matlab 
session, select Save Workspace As from the File menu.
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Matlab’s Window: Command HistoryMatlab’s Window: Command History

Select one or more lines and 
right-click to copy and re-
use the command with the 
command window, to 
evaluate it or to create an 
m-file.

Statements that enter in 
the Command Window
are logged in the 
Command History. In the 
Command History, you 
can view previously run 
statements, and copy and 
execute selected 
statements.
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Matlab’s Window: Current DirectoryMatlab’s Window: Current Directory

Matlab file operations use the current directory and the search 
path (File> Set Path…) as reference points. Any file you want to 
run must either be in the current directory or on the search 
path. A quick way to view or change the current directory is by 
using the Current Directory field in the desktop toolbar. To 
search for, view, open, and make changes to Matlab - related 
directories and files, use the Matlab Current Directory Browser 
which is called after clicking the icon:    .
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Matlab Variable NamesMatlab Variable Names

Variable names are case sensitive:
Accepted variables names do not start with symbols (e,g: 
~, _ ) or numbers, use lower and upper case letters, do 
not exceed 63 characters and do not resemble reserved 
works and build-in functions.

Matlab recognizes only one type of variable:
scalar: 1-by-1 array
vector: 1-by-c (row vector with c columns)

1-by-r (column vector with r rows)
array: an r-by-c array (a matrix with r rows and c  

columns)  



Prepared by: Panayiotis Andreou, for PBA - UCY

11

Matlab Data TypesMatlab Data Types

The data type is a classification of particular type 
information:

integer a whole number, a number without any fraction 
(e.g. 12); 

floating point a number with a fractional part (e.g. 25.7)

character readable text character (e.g. 'Matlab'). 

With Matlab, it is not needed to type or declare variables. Any 
operation that assigns a value to a variable creates the 
variable, if needed, or overwrites its current value, if it already 
exists. 
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Matlab’s Command Window is an active calculator in which 
mathematical statements are executed. At minimum, Matlab 
is a scientific calculator that can perform all operations that 
are carried out from pocket scientific calculators.

User is allowed to assign a name to an expression. After 
assigning the name, this expression becomes a variable 
(scalar, vector or matrix) with a certain data type.

All expressions entered, are saved in the Matlab’s workspace 
and can be recalled in a later stage with their variable name.

If no variable name is given to an expression, Matlab 
automatically assigns the name: ansans
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Math and Assignment OperatorsMath and Assignment Operators

Basic Math Operators:
Addition and unary addition: ++

Subtraction and unary subtraction: --

Power: ^̂

Division: //

Left division: \\

Assignment Operator:
Assignment: ==

Special Character:
Bracket: ()()



Prepared by: Panayiotis Andreou, for PBA - UCY

14

ExamplesExamples

In the command window enter the following:

ResultResultInput CommandInput Command

ans=0.5000>>10\5

ans=2>>10/5

ans=2>>(((2*(2+1)^2)/3)/9)*3

ans=9.8511>>52/47*8+1

ans=11>>(5*2+1)

ans=6>>8-2

ans=2>>1+1
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Help FacilitiesHelp Facilities

Matlab has additional operators except those exhibited 
previously. How can you find them?

Matlab is a technical software that is enhanced with extensive 
online help, via various help facilities that follow: 

If the user knows the topic in 
which an informative help tip is 
needed it can use the help command. 

The problem with the help
command is that the user must be 
familiar with the topic under 
consideration and the word following 
the help command must be exact and 
spell correctly.

If the user knows the topic in 
which an informative help tip is 
needed it can use the helphelp command. 

The problem with the helphelp
command is that the user must be 
familiar with the topic under 
consideration and the word following 
the helphelp command must be exact and 
spell correctly.

1. help command

2. lookfor command

3. Help Browser

1.1. helphelp command

2.2. lookforlookfor command

3. Help Browser
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Help FacilitiesHelp Facilities

Matlab has additional operators except those exhibited 
previously. How can you find them?

Matlab is a technical software that is enhanced with extensive 
online help, via various help facilities that follow: 

1. help command

2. lookfor command

3. Help Browser

1.1. helphelp command

2.2. lookforlookfor command

3. Help Browser

Example: 
In the command window type:

>> help operators
>> help ops
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Help FacilitiesHelp Facilities

Matlab has additional operators except those exhibited 
previously. How can you find them?

Matlab is a technical software that is enhanced with extensive 
online help, via various help facilities that follow: 

More flexible for pursuing help 
from Matlab when the user is not 
familiar with the exact key word. It 
looks for the given string in the first 
comment line of the help text in all 
m-files located in Matlab’s toolboxes. 

It is time consuming and 
sometimes takes up to some minutes 
to come up with a result. 

More flexible for pursuing help 
from Matlab when the user is not 
familiar with the exact key word. It 
looks for the given string in the first 
comment line of the help text in all 
m-files located in Matlab’s toolboxes. 

It is time consuming and 
sometimes takes up to some minutes 
to come up with a result. 

1. help command

2. lookfor command

3. Help Browser

1.1. helphelp command

2.2. lookforlookfor command

3. Help Browser
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Help FacilitiesHelp Facilities

Matlab has additional operators except those exhibited 
previously. How can you find them?

Matlab is a technical software that is enhanced with extensive 
online help, via various help facilities that follow: 

1. help command

2. lookfor command

3. Help Browser

1.1. helphelp command

2.2. lookforlookfor command

3. Help Browser

Example: 
In the command window type:

>> lookfor operators
>> lookfor ops
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Help FacilitiesHelp Facilities

Matlab has additional operators except those exhibited 
previously. How can you find them?

Matlab is a technical software that is enhanced with extensive 
online help, via various help facilities that follow: 

Online help can also be obtained 
via the Help menu found in the 
Matlab’s desktop. From the toolbar, 
select Help>Matlab Help to get the 
help browser with a list of help 
topics. Through this screen, the user 
can navigate around a variety of 
topics by double clicking on them 
(this browser displays html help 
pages and can be operate like the 
Internet Explorer).

Online help can also be obtained 
via the Help menu found in the 
Matlab’s desktop. From the toolbar, 
select Help>Matlab Help to get the 
help browser with a list of help 
topics. Through this screen, the user 
can navigate around a variety of 
topics by double clicking on them 
(this browser displays html help 
pages and can be operate like the 
Internet Explorer).

1. help command

2. lookfor command

3. Help Browser

1.1. helphelp command

2.2. lookforlookfor command

3. Help Browser
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Help BrowserHelp Browser

Available Toolboxes HelpAvailable Toolboxes Help
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Examples with Elementary FunctionsExamples with Elementary Functions

In the command window type: “help help elfun” and carry out the 
following examples: 

Rounding and RemainderRR3= 2>> RR3=rem(8,3)

Rounding and RemainderRR2= 1>> RR2=round(1.252)

>> RR1= fix(2.587)

>> Exp3=sqrt(25)

>> Exp2=log(2)

>> Exp1=exp(1)

>>Tr3=tan(2.5)

>> Tr2=cos(5)

>> Tr1=sin(0.1)

Input CommandInput Command TypeTypeResultResult

Rounding and RemainderRR1=2

ExponentialExp3=5

ExponentialExp2=0.6931

ExponentialExp1=2.7183

TrigonometricTr3=-0.7470

TrigonometricTr2 = 0.2837

TrigonometricTr1 = 0.0998
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Controlling Command Window and WorkspaceControlling Command Window and Workspace

The variables that you have assigned previously are saved in the
workspace. Type their name at the prompt “>>” to recall them.

Useful Commands:

whowho: : Lists current variables located in the workspace.

whoswhos: : Is a long form of whowho.  It lists all the variables in the current workspace, 
together with information about their size, bytes, class, etc.

clear allclear all: : Clear all variables and functions from memory.

homehome: : Moves the cursor to the upper left corner of the command window and 
clears the visible portion of the window.   

clcclc: : Clears the command window and homes the cursor.

quitquit: : Terminates Matlab.

whatwhat: : Lists all Matlab files (m-files) in current directory

dir, dir, cdcd, , cdcd ....: : Likewise DOS
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The The formatformat CommandCommand

The formatformat function controls the numeric format of the values 
displayed by Matlab. The function affects only how numbers are 
displayed, not how Matlab computes or saves them. 

In the command window, type first the formatformat command and then 
recall a workspace variable (e.g. Exp1):

format short eformat short e: : Floating point format with 5 digits.

format short gformat short g: : Best of fixed or floating point format with 5 
digits.

format long eformat long e: : Floating point format with 15 digits.

format long gformat long g: : Best of fixed or floating point format with 15 
digits.

format bankformat bank: : Fixed format for dollars and cents.

Use the helphelp command to see more formats.
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Matlab Special VariablesMatlab Special Variables

Specify range (e.g. starting_value:step:finishing_value) :

Insert a comment line. %

Suppress output and rows in matrices.;

Separates statements and vector elements. ,

Continue a long statement to the next line.…

Positive infinitive (e.g. 1/0).Inf

Not a Number (e.g. 0/0, Inf/Inf).NaN

Largest positive floating point number (= 1.7977e+308.reamax

Smallest positive floating point number (=2.2251e-308).realmin

Machine precision. Floating point relative accuracy.eps

The Matlab value for πpi
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Command Line EditingCommand Line Editing

Various arrow and control keys on your keyboard allow you to recall, 
edit, and reuse statements you have typed earlier. For example, 
suppose you mistakenly enter:

>> G = (1 + sqt(5))*sin(pi)

You have misspelled square root function: sqrtsqrt. Matlab responds with:

“Undefined function or variable 'sqt'”

Instead of retyping the entire line, simply press the key. The 
statement you typed is redisplayed. Use the     key to move the cursor 
over and insert the missing “r”. Repeated use of the   key recalls earlier 
lines. Typing a few characters and then the   key finds a previous line 
that begins with those characters. You can also copy previously 
executed statements from the Command History window. 
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Given a set of parameters, it gives the value of a European 
call or put option. 

)d(NXe)d(NSec rTTδBSM
21

−− −=

Tσ/)Τ)/σδr()X/S(ln(d 22
1 +−+= Tσdd −= 12

S: Current stock value (underlying asset)
X: Option’s exercise price
T: Time to maturity in years fraction
σ: Stock’s volatility/log-relative returns standard deviation (%)
r: Continuously compounded risk free rate with maturity T (%)
δ: Stock’s dividend yield (%)
N(.): cumulative normal distribution function N(0,1)
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Practicing the BSM FormulaPracticing the BSM Formula
Notice that the Matlab build in function for square root is sqrtsqrt()(), for 
natural logarithm is log()log(), for exponential is exp()exp(), and for the 
standard normal cumulative distribution is normcdfnormcdf()().

In the command window write:

>> S=105, X=100, T=0.1, sig=0.25, r=0.05, div=0.02

>> d1=(loglog(S/X)+(r-div+sig^2/2)*T)/(sig*sqrtsqrt(T))

>> d2=d1-sig*sqrtsqrt(T); Nd1=normcdfnormcdf(d1); Nd2=normcdfnormcdf(d2);

>> Call=S*expexp(-div*T)*Nd1-X*expexp(-r*T)*Nd2   

After you type all commands, the correct price for the call option is: 
Call = 6.5321.

Observe that multiple statements can be entered in one line if they 
are separated by “,” or “;” (what is their difference).   
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VectorsVectors

A vector is a list of numbers separated by either space or 
commas. Each different number/entry located in the vector is 
termed as either element or component. The number of the 
vector elements/components determines the lengthlength of the 
vector. In Matlab, square brackets “[ ]” are used to both 
define a vector and a matrix.

Matlab can handle both row and column vectors. A row vector 
is produced by the transpose of a column vector and vise 
versa. Matlab returns the transpose of a vector when ' follows 
the definition of a vector.

Build in functions of vectors are executed element-wise.  
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Examples with VectorsExamples with Vectors

xx = 2     xy=  1

5    8

8    -9

>> xx=X', xy=[1; 8; -9]

X=  2.0000    5.0000    8.0000>> expexp(loglog(X))

X= 2     5     8>> X=[2:3:10]

X= 2     5     8    11>> X=[2:3:11]

X= 1   2   3>> X=1:3

y= 10.0000  14.7781  -2.0000    6.2832>> y=2*y

L= 4>> L=lengthlength(y)

y= 5  7.3891   -1  3.1416>> y=[5 expexp(2) signsign(-5) pipi]

OutputOutputInput Input 



Prepared by: Panayiotis Andreou, for PBA - UCY

30

Examples with VectorsExamples with Vectors

v1=1     3     4     6     7,   v2=[]>> v1(2:3:end)=[], v2=[]

ans=-0.9640  -0.7616   0    0.7616>> tanh(log(sqrt(exp(v2))))

ans= -2     0     2>> v2(2:endend)

ans= 4>> v7=[v4']; lengthlength(v7)

v6=5     5    -1    -1>> v6(1:2)=5; v6(3:4)=-1

v5= 1    -2     0>> v5=[v1(1) v4(endend) v2(endend-1)]

v4= 3     5     7    -2>> v4=[v1(3:2:8) v2(2)]

v3= 2   3   4>> v3=v1(2:4)

v1= 1   2   3   4   5   6   7   8

v2= -4    -2     0     2

>> v1=1:8, v2=-4:2:2

OutputOutputInput Input 
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Vectors’ Mathematical OperationsVectors’ Mathematical Operations

When manipulating row and column vectors, pay attention to have 
similar lengths.

ddiv2= 2   Inf    -1    -1>> ddiv2=(u./w')'

ddiv1=0.5000  0  -1.0000 -1.0000>> ddiv1=w./u'

dprod2= 4     0     8    -1>> dprod2=u'.*u'.*w

dprod1= 2     0    -4    -1>> dprod1=w.*u'

prod3= 6>> prod3 = w*w'

prod2= 3.5000>> prod2 = (2+w)*(u/2)

prod1=-3>> prod1 = w * u

Nothing is displayed>> w=[1 0 2 -1]; u=[2; 4; -2; 1]; 

OutputOutputInput Input 



Prepared by: Panayiotis Andreou, for PBA - UCY

32

Vectors’ Mathematical OperationsVectors’ Mathematical Operations

ans= NaN 1.0000  1.0000  1.0000>> ans./ans

ans=  0   1.0000   4.0000  9.0000>> ans.*ans

ans = 0   1.0000   2.0000   3.0000>> d.*d

ans=  0   1.0000   4.0000  9.0000>> d.^4

ans = 0   1.0000   2.0000   3.0000>> d.^2

ans= 0.4621  0.7616  1.0000  1.0000>> (expexp(x)-expexp(-x))./(expexp(x)+expexp(-x))

Nothing is displayed>> x=[0.5 1 20 50]; d=sqrtsqrt(0:3);

Displays, cleans workspace>> who, clear all

OutputOutputInput Input 

When manipulating row and column vectors, pay attention to have 
similar lengths.
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The BSM RevisitedThe BSM Revisited

Let’s say that we want to price European call options for the 
following values of S, X and T with all other data the same:

(90, 100, 0.1), (80,150, 0.15), (100, 80, 2), (10,10, 1)

In the command window write:

>> S=[90 80 100 10], X=[100 150 80 10], T=[0.1 0.15 2 1]

>> sig=0.25, r=0.05, div=0.02

>> d1=(loglog(S./X)+(r-div+(sig.^2)./2).*T)./(sig.*sqrtsqrt(T))

>> d2=d1-sig.*sqrtsqrt(T); Nd1=normcdfnormcdf(d1); Nd2=normcdfnormcdf(d2);

>> Call=S.*expexp(-div.*T).*Nd1-X.*expexp(-r.*T).*Nd2   

After you type all commands, the correct price for the call option is: 
Call = 0.3439    0.0000   27.1985    1.1124
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Two Dimensional Arrays: MatricesTwo Dimensional Arrays: Matrices

A two dimensional array is a composition of row and column vectors, 
created by using spaces (or commas) and semicolons.

A2=  -1     0     1     2

1     2     3     4

-1     0     1     2

1     2     3     4

NaN   Inf     1    -2

>> A2=[A1;A1;[NaN Inf 1 -2]]

A1= -1     0     1     2

1     2     3     4

>> A1=[B;C]

Nothing is displayed>> B=linspacelinspace(-1,2,4); C=1:4;

Cleans workspace and homes cursor>> clear all, clc

OutputOutputInput Input 
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Two Dimensional Arrays: MatricesTwo Dimensional Arrays: Matrices

A two dimensional array is a composition of row and column vectors, 
created by using spaces (or commas) and semicolons.

A4 =   0     2   Inf

1     3     1

2     4    -2

>> A4=[A2(1:2,2:4); A2(5,2:4)]'

A3=   -1     3   Inf>> A3=[A2(1,1) A2(2,3) A2(10)]

ans = -1     0     1     2>> A2(1,:)

ans = -1     1    -1     1   NaN>> A2(:,1)'

M= 5    N=4>> [M N]=sizesize(A2)

OutputOutputInput Input 
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Matrices Mathematical OperationsMatrices Mathematical Operations

Matrices mathematical operations follow the same rationale as with 
vectors’.

ans= -19  >> G(1,:)*P

ans= 7.9056>> (G.*G./([P,P]+1)*P)'*(P-8.5)

ans= 4.5000   -9.5000

8.5000   67.0000

>> G.^3/2+[P,P]./2

ans = -10.0000  -10.5000>> ([P+2,P./2]*G(:,2))'

ans= 787>> P'*G*G*P

ans= -19    61>> (G*P)'

Displays, cleans workspace>> G=[1 -3; 2 5]; P=[8; 9];

OutputOutputInput Input 
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The BSM Revisited (Sensitivities)The BSM Revisited (Sensitivities)

Let say that we want to price European call options for the following 
values of S, T and r with all other data the same:

100100100100

100100100100

115110105100

S

0.10.10.10.1

0.300.250.200.15

0.10.10.10.1

T

0.01

0.05

0.05

0.040.030.02

0.050.050.05 r

0.050.050.05

X = 100, σ= 0.25, 

δ= 0.02
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The BSM Revisited (Sensitivities)The BSM Revisited (Sensitivities)
In the command window write:

>> S=[100:5:115]; S(2:3,:)=100; X=100; sig=0.25; div=0.02;

>> T(1:3,1:4)=0.1; T(2,:)=0.15:0.05:0.30

>> r(1:2,1:4)=0.05; r=[r; 0.01 0.02 0.03 0.04]

>> d1=(loglog(S./X)+(r-div+sig.^2./2).*T)./(sig.*sqrtsqrt(T))

>> d2=d1-sig.*sqrtsqrt(T); Nd1=normcdfnormcdf(d1); Nd2=normcdfnormcdf(d2);

>> Call=S.*expexp(-div.*T).*Nd1-X.*expexp(-r.*T).*Nd2   

After you type all commands, the correct price for the call option is: 
Call = 3.2938    6.5321   10.7024   15.3878

4.0690    4.7312    5.3208    5.8585

3.0987    3.1468    3.1953    3.2444
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2D Plots2D Plots

There are powerful build in functions for creating 2D plots. Matlab can 
plot one vector Vs another. Always, the first vector is taken to be the 
abscissa vector (x-axis) and the second the ordinate (y-axis). Always, 
to create a 2D plot the length of the plotted vectors should be the 
same.

There is the possibility to plot a vector Vs its index. That is, if only one 
vector is called with the plot command, then Matlab plots each element 
of the input vector in the ordinate (y-axis) Vs an index in the x-axis 
(Index=[1, 2, …, lengthlength(input_vector)]).

Via a set of additional commands, a figure plot can be given a title, a 
label to its axis, add text anywhere in the plot, etc. 
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2D Plots2D Plots

A 2D line (or mark) plot is created via the plotplot() build in function. It 
general calling syntax is:

plotplot(X,Y, '#@$')

where: # represents a color Matlab symbol
@ represents a mark Matlab symbol
$ represents a line Matlab symbol

Pentagram, hexagram and solidp, h,

Triangles: up, left and right ^, <, >Blackk

Diamond and triangle down d, vYellowy

Plus, star and square+, *, sMagentam

Point, circle and x-mark., o, xCyanc

Mark Style (@)SymbolRedr

Solid, dotted, dash dot and dashed-, :, -., --Green g

Line Style ($)SymbolColor (#)Symbol
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2D Examples2D Examples
Insert the following examples to the command window in order to 
plot the function f(x) in the area [0,5] and experiment with 
additional features related to plots:

)x/()xx()x(f 5152 32 −−+=

>> x=0:0.5:5; y=(2*x.^2+5*x-1)./(x.^3-5); plot(x,y);

>> x=0:0.25:5; y=(2*x.^2+5*x-1)./(x.^3-5); plot(x,y, 'rh-.');

>> xlabel('x-values'); ylabel('y-values'); title('y=(2x^2+5x-1)/(x^3-5)');

>> hold on; y1=rand(1,length(y)); plot(x,y1, 'g*-- '); 

>> close all; plot(x,y, 'bp--',x,log(y1.^2), 'rh',x,x+zeros(1,length(x)), 'ms');

>> legend('y','log(y1^2)','x'); title('Various Plots');

>> figure; x=linspace(0,2*pi,25); subplot(3,1,1); plot(x, sin(x),'r*-.'); ylabel('sin(x)');

>> subplot(3,1,2); plot(x, cos(x),'gh-.'); ylabel('cos(x)');

>> subplot(3,1,3); plot(x, x.*sin(x), 'r*'); ylabel('x*sin(x)');
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2D Examples2D Examples
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>> x=0:0.5:5; y=(2*x.^2+5*x-1)./(x.^3-5); plotplot(x,y);
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2D Examples2D Examples
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>> x=0:0.25:5; y=(2*x.^2+5*x-1)./(x.^3-5); plotplot(x,y, 'rh-.');
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2D Examples2D Examples
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y=(2x2+5x-1)/(x3-5)
>> xlabelxlabel('x-values'); ylabelylabel('y-values'); titletitle('y=(2x^2+5x-1)/(x^3-5)');
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2D Examples2D Examples

>> hold onhold on; y1=randrand(1,lengthlength(y)); plotplot(x,y1, 'g*-- ');
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y=(2x2+5x-1)/(x3-5)
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2D Examples2D Examples

>> close allclose all; plotplot(x, y, 'bp--', x, loglog(y1.^2), 'rh', x, x+zeroszeros(1,lengthlength(x)), 'ms');
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2D Examples2D Examples

>> legendlegend('y', 'log(y1^2)', 'x'); titletitle('Various Plots');
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2D Examples2D Examples
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>> figurefigure; x=linspacelinspace(0,2*pipi,25); 
>> subplotsubplot(3,1,1); plotplot(x, sin(x),'r*-.'); ylabelylabel('sin(x)');
>> subplotsubplot(3,1,2); plotplot(x, cos(x),'gh-.'); ylabelylabel('cos(x)');
>> subplotsubplot(3,1,3); plotplot(x, x.*sin(x), 'r*'); ylabelylabel('x*sin(x)');
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3D Line Plots3D Line Plots
>> g=linspace(-5*pi,5*pi,200); plot3(sin(g), cos(g), g, 'r*-');

>> xlabel('x'); ylabel('y'); zlabel('z'); title('A helix');
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3D Surface Graphs3D Surface Graphs

If it is needed to evaluate a bivariate function, f(x,y), at each 
(x,y) pair you should evaluate a value for f(.). 

To plot the surface, it is needed to create a grid of sample points 
(most preferable with high density) that cover the rectangular 
domain of the (x, y) plane in order to generate X and Y matrices 
consisting of repeated rows and columns, respectively, over the 
domain of the function. Then these matrices will be used to 
evaluate and graph the function. 

The meshgridmeshgrid function transforms the domain specified by two 
vectors, x and y, into matrices, X and Y. You then use these 
matrices to evaluate functions of two variables. The rows of X
are copies of the vector x and the columns of Y are copies of the 
vector y.
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3D Surface Graphs3D Surface Graphs

Let’s plot the peaks function with functional form: 

222222 15312

3
1

5
1013 y)x(yx)y(x ee)yxx(e)x()y,x(fZ −+−−−+−− −−−−−==

In the command window write:

>> clear allclear all; x=-2:0.25:2; y=-4:0.5:4; [X Y]=meshgridmeshgrid(x,y);

>> plotplot(X,Y, 'rh'); axisaxis([-3 3 -5 5]); 

>> xlabelxlabel('x-axis'); ylabelylabel('y-axis'); titletitle('Meshgrid'); 

>> grid on;

View the plot in the next slide to understand the meshgridmeshgrid
functioning.
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3D Surface Graphs 3D Surface Graphs -- meshgridmeshgrid
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Observe that meshgridmeshgrid has sampled all possible interior points of 
the (x, y) plane. 
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3D Surface Graphs 3D Surface Graphs -- meshmesh

>> Z =3*(1-X).^2.*exp(-(X.^2) - (Y+1).^2)- 10*(X/5-X.^3- ...                                             

Y.^5).*exp(-X.^2-Y.^2)-1/3*exp(-(X+1).^2-Y.^2);

>> mesh(X, Y, Z); xlabel('x'); ylabel('y'); zlabel('Z'); title('Peaks');
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3D Surface Graphs 3D Surface Graphs -- surfsurf

>> figurefigure; meshmesh(X, Y, Z); ); xlabelxlabel('x'); ylabelylabel('y'); zlabelzlabel('Z'); titletitle('Peaks');
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Matlab Editor/DebuggerMatlab Editor/Debugger
Use the Editor/Debugger to create and debug m-files, which are programs 
you write to run Matlab functions. To open the Editor/Debugger window go: 
File>New>M-file
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BSM with Editor/DebuggerBSM with Editor/Debugger

Open the Editor/Debugger either via the File>New>M-File from the 
menu or by clicking the      icon on Matlab’s desktop.

Write the set of commands needed to:

Price call options for the following parameter values:

S= 60:5:130, X= 100, T= 0.1, σ= 0.25, r= 0.05, δ= 0.02

Plot the call values Vs S

Make the 3D surface of call Vs S Vs T for the following ranges:

S=80:2:120, T= 0.1:0.02:0.3

The resulting file is a script and it is saved a an m-file  with a name 
(e.g. pres_BSM.m). To run the script either select: Debug>Save and 
Run or save it in a directory, go to the command window and at “>>” 
write its name without the .m extension (notice that the current 
directory should be the one that you save the file).
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What is a Script?What is a Script?

Scripts can operate on existing data in the workspace, or they can 

create new data on which to operate. Although scripts do not return 

output arguments, any variables that they create remain in the 

workspace, to be used in subsequent computations. Scripts are useful 

for automating a series of steps that are needed to be performed many 

times.

A script has no a specific structure. It includes a number of commands 

that are serially executed. As long as the command series has a logical 

interpretation, the script will result to the desire output. Remember that 

a script does not take and does not return input and output arguments 

respectively. The vectors and matrices (variables or scalars) are stored 

in the Matlab’s workspace.
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• Script location and name
• * indicates that script is not saved

• Script location and name
• * indicates that script is not saved

• Indicates that is a script• Indicates that is a script

58
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Relational and Logical OperatorsRelational and Logical Operators

To compare various “quantities” (e.g. A=B) or to define a logical 
condition (X>2) Matlab offers the following alternatives (in 
order of precedence): 

Logical Operators:Logical Operators:Relational Operators:Relational Operators:

not:   ~

and:   &

or:     |

Logical Functions:Logical Functions:
any(x), all(x)

Less Than:                      <

Less Than or Equal:       <=

Greater Than:                 >

Greater Than or Equal:  >=

Equal To:                         ==

Not Equal To:                 ~=

Less Than:                      <<

Less Than or Equal:       <=<=

Greater Than:                 >>

Greater Than or Equal:  >=>=

Equal To:                         ====

Not Equal To:                 ~=~=

Logical Functions: Given that xx is a vector, anyany(x) returns 1 if 
any element of xx is nonzero and allall(x) returns 11 if all elements of xx
are nonzero.
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Finally all result to a Boolean expression that takes two values: TRUE (1) and 
FALSE (0). Always the comparisons are done element by element and the result 
is a scalar/vector/matrix of the same size with elements set to 1 where the 
relation is true and elements set to 0 where it is not.

Examples Examples -- Relational and Logical OperatorsRelational and Logical Operators
60

A7=0,  A8=1>> A7=allall(D), A8=allall(E)

A5=1,  A6=1>> A5=anyany(D), A6=anyany(E)

ans= 1 1     0>> ~D | (D~=E)

ans= 0,  A4=1>> A==B & C~=B, A4= -2 & 5

A1= 0,  A2= 1, A3= 0   1  0>>A1= ~A, A2= ~B, A3= ~D

ans= 0     0     1>> D==E

ans= 1     0     1>> D>=E

ans=1, 0, 0, 1, 1, 1>>A>1, A>=10, A<5, C<=B, D(2)==B, D(3)~=8
Nothing is displayed>> A=5; B=0; C=-5; D=[-1 0 1]; E=[-2 8 1];

OutputOutputInput Input 
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Conditional Statements and LoopsConditional Statements and Loops

The relational and logical operators are very useful when it is 
needed to either execute a conditional statement or when a 
segment of commands are needed to be executed a number of 
times.

A conditional statement is a segment of programming code that 
evaluates a statement; if the statement is TRUE then it executes
some commands, otherwise if it is FALSE it runs a bulk of different 
programming code:

Two most importantTwo most important: if … end and switch … end

Loops can execute a bulk of commands as long as an expression is
TRUE or for a specific number of time:

Most importantMost important: for .. end, while … end
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The The if if Conditional ExpressionConditional Expression
62

sales=5000;
if sales<1000

Profit=sales*0.1;
else

Profit=(sales-1000)*0.2+1000*0.1
end

if logical expression
programming code executed if TRUE

else
programming code executed if FALSE

end

flag=0;
if ~flag 

disp('Hello')
end

if logical expression
programming code executed if TRUE

end

if (sales>1000 & sales<=2000)
disp('Low Sales '); 
Profit=sale*0.1

elseif (sales>2000 & sales<=10000)
disp('Medium Sales ');
Profit=sales*0.15

else
disp('Satisfactory Sales ');
Profit=sales*0.17

end

if logical expression #1
programming code executed if TRUE #1

elseif logical expression #2
programming code executed if TRUE #2

else 
programming code executed if FALSE

end

ExampleSyntax
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The The switch switch Conditional StatementConditional Statement
63

dice=3;
switch (dice)

case 1
disp('One')

case 2
disp('Two')

case 3
disp('Three ')

case 4
disp('Four')

case 5 
disp('Five')

otherwise
disp('Six')

end

switch expression

case choice #1                                                       

segment of executable programming code

case choice #2

segment of executable programming code

otherwise

segment of executable programming code

end

ExampleSyntax

It executes groups of statements based on the value of a variable or 
expression. Only the first matching case is executed. The expression 
following the case case should be either a scalar or a string. 
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The The for for LoopLoop
64

for i=1:10

disp(i)

end
sumj=0;

for j=25:-2:-12

sumj=sumj+j

end

for index=first_value:step:last_value

segment of executable programming code

end

ExampleExampleSyntaxSyntax

The colon notation is similar as in the case of the vectors. Actually, 
index in the forfor syntax is a vector with n elements with first element 
being the first_value and last the last_value. The difference between 
the index elements is step. If step is not displayed, then by default is 
set to 1.
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The The while while LoopLoop
65

X=-3;

while X<=10

disp(X)

X=X+1;

end

while expression

segment of executable programming code

end

ExampleExampleSyntaxSyntax

The whilewhile loop repeats a group of statements an indefinite number 

of times under control of a loical condition. That is, as long as an 

expression is TRUE, then the segment of executable programming 

code that is included in the while while statement is executed. 
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FunctionsFunctions

They are m-files that can accept input arguments and 
return output arguments. The name of the m-file and of 
the function should be the same. 

They operate on variables within their own workspace, 
separate from the workspace you access at the Matlab 
command prompt. 

They are useful for extending the existing Matlab 
language for personal applications.

Functions are included in scripts and have their own 
calling syntax. 
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Function’s StructureFunction’s Structure

A functions has a very specific calling structure 
(for example):

Matlab function names have the same 
constraints as variable names. The name must 
begin with a letter, which may be followed by 
any combination of letters, digits, and 
underscores. 
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Function’s StructureFunction’s Structure

If the filename and the function definition line name are 
different, the internal (function) name is ignored. Thus, if 
pres_pres_DiagExtractDiagExtract.m.m is the file that defines a function 
named: diagonal_extractiondiagonal_extraction, you would invoke the 
function by typing in the command window:

“pres_pres_DiagExtractDiagExtract”

Concerning function arguments, if the function has 
multiple output values, enclose the output argument list in 
square brackets. Input arguments, if present, are enclosed 
in parentheses. Use commas to separate multiple inputs or 
output arguments. Here's a more complicated example:

“function [Abs, Mean, Std] = function [Abs, Mean, Std] = StatistiSStatistiS(X, Y, Z)(X, Y, Z)”
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Function’s StructureFunction’s Structure

The H1 Line:

The H1 line, so named because it is the first help text 
line, is a comment line immediately following the 
function definition line. Because it consists of comment 
text, the H1 line begins with a percent sign, ‘%’.

This is the first line of text that appears when a user 
types helphelp “function_name” at the Matlab prompt. 
Further, the lookforlookfor searches and displays only the H1 
line of the functions. Because this line provides 
important summary information about the m-file, it is 
important to make it as descriptive as possible. 
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Function’s StructureFunction’s Structure

The Help Text:

You can create online help for your m-files by entering 
text on one or more comment lines, beginning with the line 
immediately following the H1 line. 

When you type help function_name, Matlab displays the 
comment lines that appear between the function definition 
line and the first non-comment line. The help system ignores 
any comment lines that appear after this help block. 
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Function’s StructureFunction’s Structure

The Body Text:

The function body contains 
all the Matlab code that 
performs computations and 
assigns values to output 
arguments. The statements in 
the function body can consist 
of function calls, progra-
mming constructs like flow 
control and interactive input 
and output, calculations, assig-
nments, comments, and blank 
lines.
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Function’s StructureFunction’s Structure

• Indicates that is a function• Indicates that is a function
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The BSM Revisited: A The BSM Revisited: A functionfunction
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The BSM Revisited: The The BSM Revisited: The scriptscript
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Loading ASCII Files of DataLoading ASCII Files of Data

Data that is saved in a text format can be loaded in the Matlab’s 
workspace with the loadload command. Readable text data do not contain 
any text (only numerical data) and all columns and rows are completely 
filled. Internet data saved in an ASCII form is similar with the ones 
shown on the above spreadsheet. The general calling syntax is:

DataMatrix =load =load ('filename')
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